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Safety in the Lab 

 You are only allowed in the laboratory when there is a 'responsible person' 

present such as a demonstrator or the laboratory staff.  

 

 Do not touch any equipment or machines kept in the lab unless you are asked to 

do so. 

  

 A tidy laboratory is generally safer than an untidy one, so make sure that you do 

not have a confused tangle of electrical cables. Electrical equipment is legally 

required to be regularly checked, which means it should be safe and reasonably 

reliable: do not tamper or attempt to repair any electrical equipment (in 

particular, do not rewire a mains plug or change a fuse - ask one of the laboratory 

staff to do it). Never switch off the mains using the master switches mounted on 

the walls. Please make yourself aware of the fire exits when you first come into 

the lab. When the alarm sounds please leave whatever you are doing and make 

your way quickly, calmly and quietly out of the lab. You must always follow 

instructions from your demonstrators and the laboratory staff.  

 

  You must keep walkways clear at all times and in particular coats and bags must 

be stowed away safely and must not pose a trip hazard. 

 

  It is important that you make a point of reading the "Risk Assessment" sheet 

included in the manuscript of each experiment before you start work on the 

experiment. 

 

  Please take notice of any safety information given in your scripts. If an 

experiment or project requires you to wear PPE (personal protective equipment) 

such as gloves and safety glasses, then wear them. 

 

  Always enter the lab wearing your shoes. It is strictly prohibited to enter the lab 

without shoes. 

 

  There must be NO smoking, eating, drinking, use of mobile phones or using 

personal headphones in the laboratory. This last point is not because we dislike 

your choice of music but because you must remain aware of all activity around 

you and be able to hear people trying to warn you of problems. 

 

  Keep the lab neat and clean.  
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List of Experiment 

1. Sketcher workbench:  

    

a. Creating sketches 

b. Selecting &amp; Editing of Geometry, Features, Models 

c. Creating Sketcher Geometry &amp; Using Sketcher Tools 

d. Using Sketches &amp; Datum Features  

 

2. Basic Solid part modelling 

 

a. Creating Extrudes, Revolves, and Ribs 

b. Creating Holes, Shells, Draft &amp; Patterns 

c. Creating Rounds, Chamfers &amp; Using Layers  

 

3. Advance Solid Part Modeling  

 

a. Advanced Selection, Creating Sweeps and Blends 

b. Sweeps with Variable Sections 

c. Helical Sweeps &amp; Swept Blends 

d. Relations, Parameters &amp; Family Tables 

e. Measuring and Inspecting Models.  

 
4. Assembly design: 

 

a. Creating assembly with top-down approach and bottom- up approach 

b. Assembling with Constraints, Exploding, Replacing Components, 

c. Cross- Sections in Assemblies  

 

5. Drafting workbench: 

 

a. Introduction, creating new drawings and drawing views, 

b. Adding model details and tolerance information to drawings. 

c. Adding notes, symbols, tables, balloons and layers in drawings. 
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Experiment-1     

1. Sketcher workbench  :  

Create a new part. 

Click New from the Menu bar. The New SOLIDWORKS Document dialog 

box is displayed.  

Select the Advanced mode. 

⦁ If needed, click the Advanced tab. The below New SOLIDWORKS 

Document box is displayed. 

⦁ Click the Templates tab. 

⦁ Click Part. Part is the default template from the New 

SOLIDWORKS Document dialog box. 

⦁ Click OK from the New SOLIDWORKS Document dialog box. 

The Advanced mode remains selected for all new documents in the current 

SOLIDWORKS session. When you exit SOLIDWORKS, the advanced mode 

setting is saved. 

The default SOLIDWORKS installation contains three tabs in the New 

SOLIDWORKS Document dialog box: Templates, MBD, and Tutorial. The 

Templates tab corresponds to the default SOLIDWORKS templates. The 

MBD tab corresponds to the templates utilized in the SOLIDWORKS (Model 

Based Definition). The Tutorial tab corresponds to the templates utilized in 

the SOLIDWORKS Tutorials. 

            Part1 is displayed in the Feature Manager and is the name of the document. 

Part1 is              the default part window name. 

The Part Origin is displayed in blue in the centre of the Graphics window. 

The Origin represents the intersection of the three default reference planes: 

Front Plane, Top Plane and Right Plane. The positive X-axis is horizontal and 

points to the right of the Origin in the Front view. The positive Y-axis is 

vertical and points upward in the Front view.  

The Feature Manager contains a list of features, reference geometry, and 

settings utilized in the part. 

 Edit the document units directly from the Graphics window as illustrated. 
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 Command Manager tabs, Feature Manager tab, Task Pane tabs will vary depending on             

system setup, version, and Add-ins. 

 

View the Default Sketch Planes. 

⦁ Click the Front Plane from the Feature Manager. 

⦁ Click the Top Plane from the Feature Manager. 

⦁ Click the Right Plane from the Feature Manager. 

⦁ Click the Origin from the Feature Manager. The Origin is the intersection of the 

Front, Top, and Right Planes. The Origin point is displayed. 

⦁ Click inside the Graphics window. 
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Experiment-2 

Basic Solid part modelling Creating Extrudes, Revolves, and Ribs Creating Holes, 

Shells, Draft &amp; Patterns Creating Rounds, Chamfers &amp; Using Layers   

Introduction:  

In this tutorial you will build up on what you have learned in the previous tutorials by 

creating a bit more complex part using extrude, revolve and the hole tool. In addition 

to the hole tool which was introduced previously, Pro/E has several other tools that 

can be readily used for modifying existing solids. Some of these tools, such as shell, 

rip, round and chamfer, will be introduced. Datum planes are used for drawing 

sketches in order to create solid features. When there is no surface available for 

drawing a sketch at the desired location, additional datum planes can be created at that 

location. In this tutorial you will see how additional datum planes can be created. 

Creating Extrusion:  

 

1. Start Pro/E Wildfire. 
2. Choose [File] -> [Set Working Directory…], and select a folder to 

save your work in. 
3. Select [File] -> [New], and type the part name [Tutorial4] in Text Box. 
4. Click the [OK] Button. 

5. Select the Extrude icon from the Feature Creation Toolbar at 

the right of the screen. 

6. Select the Placement button then the Define 

 button from the Dashboard. 
7. Select the plane marked as FRONT to be your sketching plane then 

click the [Sketch] button. 
8. [Close] the References dialog box. 

9. Select the Line  icon from the Sketcher Toolbar and sketch the 

shape shown in Figure 4.1 and dimension it as shown in the figure. 

Note that you will need to use the Create dimension  icon to define 

the same set of dimensions shown in the figure. Remember that you 

can add the dimension between any two entities by clicking both 

entities then clicking the middle mouse button. 
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10. Click on the check  button to exit the Sketcher. 

 

11. From the Dashboard set the extrusion depth to be 125, and click the 

Check  button to complete the extrusion. 

Click on Saved view list  icon; choose [Standard Orientation]. Your part 

should look similar to that shown in Figure. 

12. Select [File] -> [Save] from Menu Bar then click [Ok] to save the part. 
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Creating shell and another extrusion: 

 Select the Shell  icon from the Toolbar at the right of the screen (or choose 

[Insert] -> [Shell] from the Menu Bar). The options of the Shell tool will be 

displayed in Dashboard at the bottom of the Pro/E main window. 

Form the Dashboard set the Thickness of the shell to be 5 and hit Enter. 

Using the left mouse button select the Front Surface as shown in Figure (it should 

become highlighted in pink as seen in the figure), then while holding down the 

[Ctrl] button on the keyboard click on the Side Surface as shown in the figure (both 

surfaces should become highlighted as seen in the figure). 

 

Click the check  button to complete the shell. Your part should look similar to 

that shown in Figure. 
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1. Select the Extrude  icon from the Feature Creation Toolbar. 

 
2. Select the [Placement] button then the [Define] button from the 

Dashboard. 
 

 
3. Select the Top Surface of the part (indicated in Figure) as your 

sketching plane, then click the [Sk button.] 

 
4. [Close] the References dialog box. 

 

 

5. Select the Rectangle  icon from Sketcher Toolbar and create the 

rectangle shown in Figure an dimension it as shown in the figure.  

 

1. Now select the two vertical lines (as indicated in Figure) and delete 

them using the [Delete] button on your keyboard. 

2. After deleting the two lines, select the Arc  icon from the 

Sketcher Toolbar and create the two tangent arcs as shown in Figure. 

Make sure that the dimensions are same as what is shown in the 

figure. 

 

Note: if the arcs you created are not tangent then you can make them tangent 

using the Impose sketcher constraint  icon then choosing the Make two 
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entities tangent icon. By clicking the line first then the arc, they will 

become tangent. 

  

1. Click on the Check  button to exit Sketcher. 

2. Click on Saved view list  icon; choose [Standard Orientation]. 
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From the Dashboard set the Extrusion depth to be 50, and click Check  button. Your part 

should look similar to that shown in Figure.  

                     

Select [File] -> [Save] from Menu Bar then click [Ok] to save the part. 

 

 

 

Important Note: The order in which you define the shell is important. Note that we 

created the second extrusion after we defined the shell, this way the second extrusion 

will not be shelled. However, if we defined the shell after creating the second extrusion, 

the two extrusions (i.e., the entire part) will be shelled. If you want to test that you can 

choose the Shell 1 from the model tree and drag it using the mouse to place it after 

Extrude 2, then rotate the part and see how Extrusion 2 become empty from the inside. 

 Creating Revolves:  

Select the Revolve  icon from the Feature Creation Toolbar. 

Select the [Placement] button then the [Define] button from the Dashboard. 

Select the Top Surface of Extrude 2 to be your sketching plane, as shown in Figure 

4.8, then select the [Sketch] button.  
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 Do not close the References window, and make sure to change the view mode to 

wireframe  such that you can see the outline of Extrude 2. 

Now we will add additional references that will help us in drawing the sketch. Click 

on the two horizontal edges of Extrude 2 and the edge of the arc as shown in Figure. 

After selecting the additional references [Close] the pop-up window. 

Select the Centerline  icon from Sketcher Toolbar. 

Click point A and point B as shown in Figure 4.10 to create a vertical center line. 
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Zoom in on Extrude 2 using the mouse wheel such you see a view similar to that in 

Figure. 

Click on the arrow next to the arc icon  then choose the Create arc by 

picking its center and endpoints icon. 

Using the left mouse button first click the center point (as shown in Figure 4.11) to be 

the center of the arc then clicking on point 1 to be the start point then clicking point 2 

to be the end point of the arc. 

 

Note: make sure that the T (tangent) appears next to the ends of the arc. If for any reason the 

auto constraints did not work and dimensions are displayed on the figure, then just make sure 

that the radius of the arc is 12.5 and the horizontal distance from the end points to the centerline 

is set to 20.  
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Select the line  icon then starting from the endpoint of the arc draw a horizontal line 

then a vertical line then a horizontal line again ending at the other endpoint of the arc, as 

shown in Figure 4.12. Set the distance between the vertical line and the centerline to be 

15 as seen in the figure.  
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Click on the check button to complete the sketch. 

 

Click on Saved view list icon; choose [Standard Orientation]. 

From the Dashboard set the Revolve angle to be 180, make sure that the revolve direction is 

correct if not flip it using the arrow  icon. 

Click the check  button to complete the revolve. Your part should now look similar to that 

shown in Figure.  
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Select [File] -> [Save] from Menu Bar then click [Ok] to save the part. 

 

Chamfering:   

1. Select the Round  icon from the Toolbar at the right of the screen (or choose 

[Insert] -> [Round] from the Menu Bar). The options of the Round tool will be 

displayed in Dashboard at the bottom of the Pro/E main window. 

 
2. From the dashboard set the Radius of the round to be 3 as seen Figure. 

 

 
3. With the left mouse button click the lower edge of Extrude 2 and all the lower 

edges of the Rip as shown in the figure.  
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Click the check  button to complete the round. Your part should look similar to that seen in 

Figure.  
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4. Select Chamfer  icon from the Toolbar at the right of the screen (or choose 

[Insert] -> [Chamfer] from the Menu Bar). The options of the Chamfer tool 

will be displayed in Dashboard at the bottom of the Pro/E main window. 
5. From the Dashboard set the chamfer depth to be 3, as seen in Figure 4.26. 
6. With the left mouse button click on the edge of the hole as shown in the figure. 

7. Click the check  button to complete the chamfer. If you followed the instructions 

correctly, your part would look similar to that shown in Figure. 
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Select [File] -> [Save] from Menu Bar then click [Ok] to save the part.  
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Experiment-3 

 

Advance Solid Part Modeling Advanced Selection, Creating Sweeps and 

Blends Sweeps with Variable Sections Helical Sweeps &amp; Swept Blends 

Relations, Parameters &amp; Family Tables Measuring and Inspecting 

Models.   

 

Introduction: 

 

Sweeps, blends and helical sweeps are some of the useful Pro/E commands that can 

be used for creating parts which can not be made using extrusions or revolves. In 

an extrusion, the cross-section moves normal to the sketching plane (i.e., moves 

along a straight line) and in a revolve, the cross-section moves around an axis (i.e., 

moves along a circle). In a sweep, however, in addition to the cross-section, you 

also sketch the path along which this cross section will be moved. Blends allow you 

to draw several “spaced” cross-sections and join them together to create a solid. 

Finally, helical sweeps allow you to draw a cross- section that moves along a helix 

such as in the case of springs or screws. 
 

Creating a swept part: 

 
1. Start Pro/E Wildfire. 
2. Choose [File] -> [Set Working Directory…], and select a 

folder to save your work in. 

3. Select [File] -> [New], and type the part name 

[Tutorial6_A] in the Text Box, then click the [Ok] 

button. 

Select [Insert] -> [Sweep] -> [Protrusion] from the Menu Bar, as seen in Figure.  

 

Important note: Similar to the Extrude and Revolve commands, you can use 

the sweep option to create a solid, cut, thin solid, etc., however, you need to 

choose the option you want before stating the sweep. 
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Two pop-up windows will open as shown in Figure 6.2. The upper pop-up window is the 

Sweep definition menu which contains all the elements that need to be defined in order 

to complete the sweep and this window will remain open until you complete the sweep. 

The small arrow (indicated in the figure) identifies the step you are currently working on. 

The lower pop- up window is the Menu Manager and the contents of this menu will 

change according to your progress. 

    

1. Select [Sketch Traj] from the SWEEP TRAJ menu in  

2. the Menu Manager. This will allow you to sketch th 

trajectory of the sweep. 
3. Select the plane labeled as FRONT, and then select [Okay] from the 
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DIRECTION menu in the Menu Manager. 

4. Select [Default] from the SKET VIEW menu in the Menu Manager. 

Pro/E will switch to the Sketcher Mode. 
5. [Close] the References pop-up window. 

6. Using the line tool  draw the path shown in Figure starting 

from point A, B, .... to pint H. Note that the yellow arrow seen in 

the sketch indicates the start point. 
7. Set the dimensions of the sketch as shown in the figure. 

  

Delete the three horizontal lines, then using the Arc tool  draw 

three tangent arcs connecting the vertical lines as seen in Figure. 
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Click the Check button  from the Sketcher Toolbar to 

complete the sketch of the trajectory. 
 

Note how the view gets rotated such that you can start drawing the cross- section of the swept 

part. The two yellow crossed lines that appear in the sketcher screen indicate the location of the 

trajectory start point. The location of your cross-section relative to that start point defines how 

the section will be swept relative to the trajectory. 

 

Using the circle tool  draw a circle centered at the crosses lines and set the diameter of the 

circle as seen in Figure. 

 



130  

                                     

1. Click the Check button  from the sketcher toolbar to 

complete the sketch of the cross-section. 

 
Note: Once you completed the definition of the cross section you can see how the swept part 

looks by clicking the [Preview] button in the Sweep definition pop-up menu, see Figure 6.6. 

Also, note that the information given in that window indicates that both elements of the sweep 

have been completed. If you need to modify any of the elements of the sweep (Trajectory or 

Section), you just need to select it from the window then press the [Define] button. 

      

  

 

 

 

 

 

 

Click the [OK] button from the Sweep definition pop-up menu to complete 

the swept part. 



131  

Select [View] -> [Orientation] -> [Standard Orientation] from the menu bar. Your part should look 

similar to that shown in Figure.  

 
     

 

 
1. Select [File] -> [Save] from Menu Bar then click [Ok] to save the part. 
2. Select [File] -> [Close window] from Menu Bar to close the 

part such that you start a new part. 
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Creating blending part:  

 
 

 

 

 

1. Select [File] -> [New], and type the part name [Tutorial6_B] in the Text 

Box, then click the [Ok] button. 

2. Select [Insert] -> [Blend] -> [Protrusion] from the Menu Bar. The 

Menu Manager pop-up window will open. 
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3. Select [Done] from the Menu Manager pop-up window. The Blend definition pop-up menu will 

now appear and it will remain open until you complete the blend. Similar to the Sweep, this 

menu contains all the elements that need to be defined in order to complete the Blend and the 

small arrow indicates the step you are currently working on. 

4. Select [Smooth] and then [Done] from the ATTRIBUTES menu in the Menu Manager. 

Select the plane labeled as FRONT, then select [Okay] from the 

DIRECTION menu in the Menu Manager, as seen in Figure.  

 

5. Select [Default] from the SKET VIEW menu in the Menu Manager. Pro/E will switch to the Sketcher 
Mode. 
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6. [Close] the References pop-up window. 

7. Draw the square shown in Figure 6.9 using the rectangle tool  and starting from 
point A to point B as shown in the figure, and then set the dimensions as seen in the 
figure. 

 
Note: A yellow arrow, as indicated in the figure, will be displayed at point 

A (if you start from point A) where this arrow indicates the start point. The meaning of start 

points for blended sections will become clear as you go on with this tutorial. 

 

 
[Figure 6.9] 

 
8. Now we will move the start point to a new location, to do so, first you need to select the 

new location of the start point by clicking on the new point such that it is highlighted in 
red (as seen in Figure 6.10) then from the menu bar select [Sketch] -> [Feature Tools] -> 
[Start Point]. 
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Now we completed the sketch of the first cross-section of the Blend, so we will 
move to the next section. 

 
9. From the Menu Bar select [Sketch] -> [Feature Tools] -> [Toggle 

Section]. 

 
Note: Once you move to the next cross-section, the previous cross- section 

will not disappear but its color will change to light gray. You still can modify 

the dimensions of the previous section if you want to do that. 

 

10. Select the line tool  and draw two diagonal lines connecting the corners of the 
square as shown in Figure 6.11. 
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Select the two diagonal lines (such that they are highlighted in red as seen in the figure, you 
need to hold down the Ctrl button on the keyboard while selecting the second line) then 
from the menu bar   
 

 
 

1. select [Edi Select the Divide an entity  icon from the Sketcher Toolbar 
(as shown in Figure 6.12) then divide the circle into four arcs by clicking on 
the points of intersection of the circle with the diagonal construction lines 
as indicated in the figure. Note that the construction diagonal lines were 
created just to be used as guidance when dividing the circle. 

 
Important note: Make sure that you divide the circle into four arcs (no less 

and no more). You can make sure that the circle is now divided to arcs by 

moving the mouse over the circumference of the circle and observing that 

each time one of the four arcs is highlighted. The reason we have to divide 

the circle into four arcs it to match the number of corners "vertices" of this 

cross-section with the previous cross-section (i.e., the square which contain 

four corners). It should be understood that blended cross sections must have 

the same number of vertices (or segments). 
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2. Once you divide the circle a start point arrow will be displayed at one of 
the points (the location of the start point depends on the order in which 
you divided the circle). If the location of your start point does not match 
the location of the start point shown in Figure 6.13, then move the start 
point to the location shown in the figure using the procedure described 
previously in step 9. 

 
 

 

Note: When the different cross-sections of a blend are joined, the start point of each cross-

section will be directly connected to the start point of the next cross-section and the 

remaining points will be connected Note that at the beginning we chose a Smooth blend and 

that option causes the cross sections to be connected using spline curves. Now we will 

change the option to Straight such that the sections will be connected using straight lines 

where that will enable us to recognize the different cross sections that we defined. To do 

that select [Attributes] from the Blend definition menu then click the [Define] button, as 

shown in Figure 6.16. 

11. Select [Straight] from the ATTRIBUTES menu in the Menu Manager, then 
select [Done]. 

12. Click the [Preview] button from the Blend definition menu and see what the 
part looks like. 

in the same order.t] -> [Toggle Construction] as shown in the figure 
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3D EXERCISES 

1. 

 

2. 
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3. 

 

4. 
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5. 

 

6. 
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7. 

 

8. 
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9. 

 

10. 
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ASSEMBLY EXERCISES 

1. 
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3. 

 

 
 


