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Safety in the Lab 

• You are only allowed in the laboratory when there is a 'responsible person' 

present such as a demonstrator or the laboratory staff. 

• Do not touch any equipment or machines kept in the lab unless you are 

asked to do so. 

 

• A tidy laboratory is generally safer than an untidy one, so make sure that 

you do not have a confused tangle of electrical cables. Electrical equipment 

is legally required to be regularly checked, which means it should be safe 

and reasonably reliable: do not tamper or attempt to repair any electrical 

equipment (in particular, do not rewire a mains plug or change a fuse - ask 

one of the laboratory staff to do it). Never switch off the mains using the 

master switches mounted on the walls. Please make yourself aware of the 

fire exits when you first come into the lab. When the alarm sounds please 

leave whatever you are doing and make your way quickly, calmly and 

quietly out of the lab. You must always follow instructions from your 

demonstrators and the laboratory staff. 

 

•  You must keep walkways clear at all times and in particular coats and bags 

must be stowed away safely and must not pose a trip hazard. 

•  It is important that you make a point of reading the "Risk Assessment" 

sheet included in the manuscript of each experiment before you start work 

on the experiment. 

 

•  Please take notice of any safety information given in your scripts. If an 

experiment or project requires you to wear PPE (personal protective 

equipment) such as gloves and safety glasses, then wear them. 

 

•  Always enter the lab wearing your shoes. It is strictly prohibited to enter 

the lab without shoes. 

 

•  There must be NO smoking, eating, drinking, use of mobile phones or 

using personal headphones in the laboratory. This last point is not because 

we dislike your choice of music but because you must remain aware of all 

activity around you and be able to hear people trying to warn you of 

problems. 

• Keep the lab neat and clean. 



                     

 

List of Experiment 
 

 
Using AutoCAD/ Solidworks / CATIA/ ProE 

 

Sl. No. List of experiment Page No. 

01 Design & drawing of Reverted joint  

02 Design & drawing of Bolted joint  

03 Design of shaft  

04 Design of bearing  

05 Design of spring  

06 Design of coupling  



LAYOUT OF SOLIDWORKS 
 

 
 
 
 
 
 

 



Experiment-1 

Design & drawing of Reverted joint 
Aim of the experiment: To design the reverted joint using SOLIDWORK. 

 
Introduction: 

 

Riveted joints are used to connect two or more components through mechanical fastening. 

This manual outlines the process of designing and drawing a riveted joint in SolidWorks. It 

includes: 

 

1. Overview of Riveted Joints 

2. SolidWorks Setup 

3. Step-by-Step Design Process 

4. Drawing the Riveted Joint 

5. Exporting and Saving Files 
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1. Overview of Riveted Joints 

Types of Riveted Joints 

• Lap Joint: Two plates overlap. 

• Butt Joint: Plates are joined edge-to-edge using cover plates. 

 

Components 

• Rivet Head 

• Shank 

• Plates 



2. SolidWorks Setup 

1. Create a New Project: 

o Open SolidWorks. 

o Select New Document → Part. 

2. Set Units: 
o Go to Options → Document Properties → Units → Set to MMGS (milli 

meters). 

 

 

 

3. Step-by-Step Design Process 

3.1 Design the Plates 

1. Create the Plate Base: 

o Go to the Front Plane → Select Sketch. 

o Draw a rectangle (e.g., 100mm x 50mm). 

o Exit the sketch and use Extruded Boss/Base to give it a thickness (e.g., 5mm). 
2. Add Holes: 

o Select the face of the plate → Sketch → Draw circles for rivet holes. 

o Use Smart Dimension to position holes. 

o Apply Extruded Cut to create holes. 

3.2 Design the Rivets 

1. Create a Rivet Head: 

o Open a new part. 

o Draw a circle (diameter = 10mm) on the Top Plane → Extrude it to 5mm. 

2. Add Shank: 

o Sketch a circle (diameter = 8mm) on the bottom face → Extrude it to 20mm. 

3. Assembly: 

o Import the plates and rivets into an Assembly Document. 

o Use Mate to position rivets in the holes. 

 

 

4. Drawing the Riveted Joint 

1. Create a Drawing: 

o Go to File → Make Drawing from Assembly. 

2. Add Views: 

o Insert Top View, Front View, and Isometric View. 
3. Dimensioning: 

o Use Smart Dimension to add all necessary dimensions (e.g., rivet diameter, 
plate thickness, hole spacing). 

 

 

 

 

 

 

 



5. Exporting and Saving Files 

1. Save Your Work: 

o Save the Part, Assembly, and Drawing files in SolidWorks format. 

2. Export as PDF: 
o Go to File → Save As → Select PDF. 

 

 

Figures and Diagrams 

Include leveled diagrams for each major step, such as: 

 

• Initial plate sketch with dimensions. 

• Rivet design and extrusion process. 

• Final assembly and drawing. 





Experiment-2 
 

 
1. Introduction 

Design & drawing of Bolted joint 

Bolted joints are commonly used for detachable connections in engineering. This manual 

provides step-by-step instructions to design and draw a bolted joint using SolidWorks. 

 

Learning Objectives: 

 

• Understand bolted joint design principles. 

• Learn to model components in SolidWorks. 

• Assemble parts to create a bolted joint. 

• Generate technical drawings with dimensions. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
• 

 
 

 

2. Components of a Bolted Joint 

1. Plates: Two plates joined by the bolt. 

2. Bolt: Includes the bolt head, shank, and threads. 

3. Nut: Engages with the bolt threads to secure the connection. 

4. Washer: Distributes load evenly. 

 

 

 

3. SolidWorks Setup 



1. Create a New Project: 

o Open SolidWorks and create a New Document → Part. 

2. Set Units: 
o Go to Options → Document Properties → Units → Set to MMGS 

(millimeters). 

 

 

 

4. Step-by-Step Design Process 

4.1 Design the Plates 

1. Plate Base: 

o Select Front Plane → Sketch. 

o Draw a rectangle (e.g., 150mm x 50mm). 

o Exit the sketch and use Extruded Boss/Base to create a thickness of 5mm. 

2. Drill Holes: 
o Select the top face of the plate → Sketch → Draw circles (e.g., diameter 

12mm). 

o Position holes using Smart Dimension. 

o Apply Extruded Cut to create through holes. 

4.2 Design the Bolt 

1. Bolt Shank: 

o Start a new part file. 

o On the Top Plane, draw a circle (e.g., diameter 10mm). 

o Extrude it to the required length (e.g., 50mm). 

2. Bolt Head: 

o On the top face of the shank, draw a hexagon (e.g., across flats = 17mm). 

o Extrude it to 8mm. 

3. Threads: 
o Apply the Thread tool to the shank for the required length. 

4.3 Design the Nut 

1. Nut Shape: 

o On the Top Plane, sketch a hexagon (e.g., across flats = 17mm). 

o Extrude it to 10mm. 

2. Internal Thread: 

o Create a circular cut for the bolt thread diameter (e.g., 10mm). 

o Use the Thread tool for internal threading. 

4.4 Design the Washer 

1. Washer Base: 

o Sketch a circle (outer diameter = 20mm, inner diameter = 12mm). 

o Extrude it to 2mm. 



5. Assembly of Bolted Joint 

1. Create Assembly Document: 

o Open a new Assembly Document. 

2. Import Parts: 

o Add the plates, bolt, nut, and washer. 

3. Mate Components: 

o Use Mate to align the bolt shank with plate holes. 

o Position the washer and nut appropriately. 

4. Final Check: 
o Ensure proper alignment and fit. 

 

 

6. Drawing the Bolted Joint 

1. Create a Drawing: 

o Open the Assembly → File → Make Drawing from Assembly. 

2. Add Views: 

o Insert Top View, Front View, Isometric View. 

3. Dimensioning: 

o Use Smart Dimension to label: 

▪ Bolt length and diameter. 
▪ Plate thickness and hole spacing. 

▪ Nut and washer dimensions. 

 

 

 

7. Export and Save 

1. Save the Project: 

o Save parts, assembly, and drawing files in SolidWorks format. 

2. Export as PDF: 
o Go to File → Save As → Select PDF for the drawing. 

Figures and Diagrams 

• Include screenshots or sketches of each step: 

o Sketching plates and drilling holes. 

o Bolt, nut, and washer design. 

o Final assembly. 

o Technical drawing 



Experiment-3 
 

 
1. Introduction 

Design of shaft 

Shafts are critical machine elements used to transmit power and rotational motion. This lab 

manual provides a step-by-step guide to design a shaft with key features like stepped 

diameters, fillets, and keyways in SolidWorks. 

 

Learning Objectives: 

• Understand the process of shaft design. 

• Use SolidWorks tools to create cylindrical and stepped shafts. 

• Incorporate features such as keyways, chamfers, and fillets. 

• Create a detailed technical drawing for manufacturing. 
 

 

 

 

 

• 
 
 

 

2. Components of a Shaft 

1. Main Body: Cylindrical structure transmitting power. 

2. Steps: Sections with varying diameters. 

3. Keyway: Slot for a key to fix gears or pulleys. 

4. Fillets and Chamfers: For stress reduction and ease of assembly. 



3. SolidWorks Setup 

1. Create a New Project: 

o Open SolidWorks → Select New Document → Part. 

2. Set Units: 
o Go to Options → Document Properties → Units → Set to MMGS 

(millimeters). 

 

 

 

4. Step-by-Step Design Process 

4.1 Create the Base Shaft 

1. Sketch the Base Profile: 

o Select Front Plane → Sketch. 

o Draw a circle for the shaft’s base diameter (e.g., 40mm). 

o Use Smart Dimension to set the diameter. 

2. Extrude the Profile: 
o Use Extruded Boss/Base to extend the circle into a cylindrical shaft (e.g., 

200mm length). 

 

 

 

4.2 Add Stepped Diameters 

1. Create Steps: 

o Select the shaft’s end face → Sketch. 

o Draw a smaller concentric circle (e.g., diameter 30mm). 

o Use Extruded Boss/Base with a specified length (e.g., 50mm). 

o Repeat for additional steps as required. 

2. Apply Fillets: 
o Use the Fillet tool to add fillets (e.g., radius = 2mm) at step transitions to 

reduce stress concentration. 

 

 

 

4.3 Design the Keyway 

1. Select the Face: 

o Choose the side face of the shaft. 

2. Sketch the Keyway: 

o Draw a rectangle (e.g., 5mm x 3mm) on the face, aligned with the shaft’s axis. 

o Position it using Smart Dimension (centered with respect to the shaft). 

3. Cut the Keyway: 
o Use Extruded Cut to remove material along the length of the shaft. 



4.4 Add Chamfers 

1. Apply Chamfer: 

o Select edges where chamfers are required (e.g., ends of the shaft). 

o Use the Chamfer tool (e.g., 1mm x 45°). 

 

 

5. Finalizing the Shaft Design 

1. Material Selection: 

o Go to Features → Material → Assign a material (e.g., Steel, Alloy Steel). 

2. Check Dimensions: 

o Use Measure and Smart Dimension tools to verify design accuracy. 

 

 

6. Technical Drawing 

1. Create a Drawing: 

o Go to File → Make Drawing from Part. 

2. Add Views: 

o Insert Front View, Top View, Isometric View. 

3. Add Dimensions: 

o Use Smart Dimension to detail: 

▪ Shaft length and diameters. 

▪ Keyway dimensions. 

▪ Fillets and chamfers. 

 

 

 

7. Export and Save 

1. Save Files: 

o Save the Part and Drawing files in SolidWorks format. 

2. Export as PDF: 
o Go to File → Save As → PDF for the drawing. 

 

 

 

Figures and Diagrams 

Include labeled diagrams for: 

 

• Shaft base profile and extrusion. 

• Stepped diameters with fillets. 

• Keyway placement and dimensions. 

• Final drawing. 



Experiment-4 

Design of Bearing 

1. Introduction 

Bearings are machine elements used to reduce friction between moving parts and support 

loads. This manual provides a step-by-step guide to design a bearing in SolidWorks, focusing 

on its housing, races, and rolling elements. 

 

Learning Objectives: 

 

• Understand the structure and design considerations of bearings. 

• Learn to create bearing components like housing, races, and rolling elements. 

• Assemble parts into a complete bearing. 

• Create a technical drawing for manufacturing. 

•  
 

 
 
 

 

2. Components of a Bearing 

1. Outer Race: Fixed outer ring. 

2. Inner Race: Rotating inner ring. 

3. Rolling Elements: Balls or rollers for motion. 
4. Cage: Holds rolling elements in position. 

5. Housing (Optional): Enclosure for the bearing. 



3. SolidWorks Setup 

1. Create a New Project: 

o Open SolidWorks → Select New Document → Part. 

2. Set Units: 
o Go to Options → Document Properties → Units → Set to MMGS 

(millimeters). 

 

 

 

4. Step-by-Step Design Process 

4.1 Design the Outer Race 

1. Sketch the Profile: 

o Select Front Plane → Sketch. 
o Draw two concentric circles (e.g., outer diameter 60mm, inner diameter 

50mm). 

2. Revolve the Sketch: 

o Use Revolved Boss/Base to create a ring with a specific depth (e.g., 15mm). 

4.2 Design the Inner Race 

1. Create a New Part: 

o Start a new part for the inner race. 

2. Sketch and Revolve: 
o Similar to the outer race, draw two concentric circles (e.g., outer diameter 

40mm, inner diameter 30mm). 

o Revolve to create a cylindrical ring with a depth of 15mm. 

4.3 Design the Rolling Elements 

1. Sketch a Sphere: 

o Select Front Plane → Sketch. 

o Draw a circle with a diameter of 10mm. 

o Use Revolve Boss/Base to create a sphere. 

2. Pattern the Balls: 
o Use the Circular Pattern tool to position multiple balls around the inner race. 

4.4 Design the Cage 

1. Sketch the Cage: 

o Create a ring similar to the outer and inner races but with slots to hold the 
balls. 

o Use Extruded Cut to create equally spaced slots. 

4.5 Design the Housing (Optional) 



1. Create the Housing: 

o Sketch a cylindrical structure to enclose the bearing. 

o Add features like mounting holes or flanges as needed. 

 

 

5. Assembly of Bearing 

1. Create Assembly Document: 

o Open a new Assembly Document. 

2. Import Components: 

o Add the outer race, inner race, rolling elements, and cage. 

3. Mate Components: 

o Use Mate to align the races concentrically. 

o Place rolling elements in the cage slots. 

 

 

6. Technical Drawing 

1. Create a Drawing: 

o Open the Assembly → File → Make Drawing from Assembly. 

2. Add Views: 

o Insert Front View, Section View, Isometric View. 

3. Add Dimensions: 

o Use Smart Dimension to detail: 

▪ Race dimensions. 
▪ Rolling element diameter and pattern. 

▪ Cage slot dimensions. 

 

 

 

7. Export and Save 

1. Save Files: 

o Save the Part and Assembly files in SolidWorks format. 

2. Export as PDF: 
o Go to File → Save As → PDF for the drawing. 

 

 

 

Figures and Diagrams 

• Include diagrams or screenshots for: 

o Outer and inner race creation. 

o Rolling element design and patterning. 

o Cage with slots. 

o Assembled bearing and technical drawing 



Experiment-5 

Design of spring 

1. Introduction 

Springs are mechanical components used to store and release energy. This lab manual 

provides a detailed guide to design a helical spring in SolidWorks. 

 

Learning Objectives: 

 

• Understand the principles of spring design. 

• Learn to create a helical spring using the Sweep tool. 

• Customize spring parameters such as coil diameter, wire thickness, and pitch. 

• Generate a technical drawing with essential dimensions. 

 

 

 

2. Types of Springs 

1. Compression Spring: Designed to resist compressive forces. 

2. Extension Spring: Designed to resist tensile forces. 

3. Torsion Spring: Designed to resist twisting forces. 

   

       



3. SolidWorks Setup 

1. Create a New Project: 

o Open SolidWorks → Select New Document → Part. 

2. Set Units: 
o Go to Options → Document Properties → Units → Set to MMGS 

(millimeters). 

 

 

 

4. Step-by-Step Design Process 

4.1 Sketch the Helix 

1. Create a Base Circle: 

o Select Top Plane → Sketch. 

o Draw a circle for the spring's base diameter (e.g., 50mm). 

o Exit the sketch. 

2. Generate a Helix: 

o Go to Features → Curves → Helix and Spiral. 

o Set the following parameters: 

▪ Type: Pitch and Revolution. 
▪ Pitch: 10mm (distance between coils). 

▪ Revolutions: 10 (number of coils). 

▪ Start Angle: 0°. 

 

 

 

4.2 Sketch the Spring Cross-Section 

1. Select a Plane: 

o Choose the Right Plane or a plane perpendicular to the helix. 
2. Sketch the Cross-Section: 

o Draw a circle for the wire diameter (e.g., 5mm). 

o Position it so the circle is tangent to the helix. 
 

 

 

4.3 Create the Spring 

1. Sweep the Profile: 

o Go to Features → Swept Boss/Base. 

o Select the sketched circle as the profile and the helix as the path. 

o Complete the operation to generate the spring. 



4.4 Add End Features (Optional) 

1. Flat Ends: 

o Select the spring ends → Use Extruded Cut to create flat surfaces. 

2. Hooks or Loops: 
o Sketch and extrude features at the spring ends for specific applications (e.g., 

extension springs). 

 

 

 

5. Technical Drawing 

1. Create a Drawing: 

o Go to File → Make Drawing from Part. 

2. Add Views: 

o Insert Front View, Top View, and Isometric View. 

3. Dimension the Spring: 

o Use Smart Dimension to add: 

▪ Coil diameter. 

▪ Wire thickness. 
▪ Pitch and number of coils. 
▪ Overall spring length. 

 

 

 

6. Export and Save 

1. Save Files: 

o Save the Part and Drawing files in SolidWorks format. 

2. Export as PDF: 

o Go to File → Save As → PDF for the drawing. 

 

 

Figures and Diagrams 

Include labeled diagrams for: 

• Helix creation with parameters. 

• Cross-section sketch for the wire. 

• Final spring with annotations. 

• Technical drawing with dimensions. 



7. Advanced Features (Optional) 

• Variable Pitch Spring: Use the Variable Pitch Helix feature to vary the 

pitch along the spring length. 

• Stress Analysis: Perform a basic stress analysis using SolidWorks Simulation. 



Experiment-6 

Design of coupling 

1. Introduction 

Couplings are mechanical devices used to connect two shafts to transmit torque and rotational 

motion. This lab manual provides step-by-step guidance to design and model a coupling in 

SolidWorks. 

 

Learning Objectives: 

 

• Understand the different types of couplings. 

• Learn to design a coupling with key features like hubs, flanges, and bolts. 

• Assemble coupling components in SolidWorks. 

• Generate a technical drawing with dimensions. 

 

 

 

2. Types of Couplings 

1. Flange Coupling: Rigid connection using flanges bolted together. 

2. Flexible Coupling: Allows slight misalignment between shafts. 

3. Oldham Coupling: Transmits torque between shafts with parallel misalignment. 

 

 

 

 

 

 

 

 

 

 

 
 

 

3. SolidWorks Setup 

1. Create a New Project: 

o Open SolidWorks → Select New Document → Part. 

2. Set Units: 
o Go to Options → Document Properties → Units → Set to MMGS 

(millimeters). 



4. Step-by-Step Design Process 

4.1 Design the Hub 

1. Sketch the Base Profile: 

o Select Front Plane → Sketch. 

o Draw a circle for the hub diameter (e.g., 60mm). 

o Draw a concentric inner circle for the shaft hole (e.g., 30mm). 
2. Extrude the Profile: 

o Use Extruded Boss/Base to extend the hub to the desired length (e.g., 40mm). 

4.2 Design the Flange 

1. Sketch the Flange: 

o Select the hub’s end face → Sketch. 

o Draw a larger concentric circle for the flange diameter (e.g., 120mm). 

o Extrude the flange to a smaller thickness (e.g., 10mm). 
2. Add Bolt Holes: 

o Sketch circles for bolt holes (e.g., diameter 12mm). 

o Use Circular Pattern to distribute holes evenly around the flange. 

4.3 Keyway and Shaft Hole 

1. Keyway: 

o Sketch a rectangle on the inner hole's surface (e.g., width 5mm, depth 3mm). 

o Use Extruded Cut to remove material for the keyway. 
2. Chamfer the Edges: 

o Apply chamfers to the shaft hole edges for easy assembly. 

 

 

4.4 Design Bolts and Nuts 

1. Bolt: 

o Create a cylinder for the bolt shank (e.g., diameter 10mm, length 50mm). 

o Add a hexagonal head (e.g., 17mm across flats) using the Extruded Boss/Base. 

2. Nut: 

o Create a hexagonal nut using similar dimensions. 

o Add internal threads using the Thread tool. 
 

 

4.5 Assemble the Coupling 

1. Create Assembly Document: 

o Open a new Assembly Document. 

2. Import Components: 

o Add two flange hubs, bolts, and nuts. 

3. Mate Components: 



o Use Mate to align the hub and flange holes concentrically. 

o Mate the bolts with the flange holes. 

o Position the nuts on the bolts. 

 

 

5. Technical Drawing 

1. Create a Drawing: 

o Open the Assembly → File → Make Drawing from Assembly. 
2. Add Views: 

o Insert Front View, Top View, and Isometric View. 

3. Add Dimensions: 

o Use Smart Dimension to label: 

▪ Hub diameter and length. 
▪ Flange diameter and bolt hole positions. 

▪ Bolt and nut dimensions. 

 

 

 

6. Export and Save 

1. Save Files: 

o Save the Part and Assembly files in SolidWorks format. 

2. Export as PDF: 
o Go to File → Save As → PDF for the drawing. 

 

 

Figures and Diagrams 

Include labeled diagrams for: 

 

• Hub and flange profiles. 

• Bolt hole pattern. 

• Fully assembled coupling. 

• Technical drawing with annotations. 

 

 

 

7. Advanced Features (Optional) 

• Flexible Coupling Design: Modify the design for a flexible or Oldham 

coupling. 

• Stress Analysis: Use SolidWorks Simulation to analyze stress distribution. 

 

 

 

 

 

 


	Automotive Design Lab
	Laboratory Location: Mechanical Engineering Dept. 2nd Floor, Room no- 326
	LAYOUT OF SOLIDWORKS
	Types of Riveted Joints
	Components

	3. Step-by-Step Design Process
	3.1 Design the Plates
	3.2 Design the Rivets
	Figures and Diagrams

	4. Step-by-Step Design Process
	4.1 Design the Plates
	4.2 Design the Bolt
	4.3 Design the Nut
	4.4 Design the Washer

	5. Assembly of Bolted Joint
	6. Drawing the Bolted Joint
	7. Export and Save
	Figures and Diagrams

	2. Components of a Shaft
	3. SolidWorks Setup
	4. Step-by-Step Design Process (1)
	4.1 Create the Base Shaft
	4.2 Add Stepped Diameters
	4.3 Design the Keyway
	4.4 Add Chamfers

	5. Finalizing the Shaft Design
	6. Technical Drawing
	7. Export and Save (1)
	Figures and Diagrams

	2. Components of a Bearing
	3. SolidWorks Setup (1)
	4. Step-by-Step Design Process (2)
	4.1 Design the Outer Race
	4.2 Design the Inner Race
	4.3 Design the Rolling Elements
	4.4 Design the Cage
	4.5 Design the Housing (Optional)

	5. Assembly of Bearing
	6. Technical Drawing (1)
	7. Export and Save (2)
	Figures and Diagrams

	3. SolidWorks Setup (2)
	4. Step-by-Step Design Process (3)
	4.1 Sketch the Helix
	4.2 Sketch the Spring Cross-Section
	4.3 Create the Spring

	2. Types of Couplings
	3. SolidWorks Setup (3)
	4. Step-by-Step Design Process (4)
	4.1 Design the Hub
	4.2 Design the Flange
	4.3 Keyway and Shaft Hole
	4.4 Design Bolts and Nuts
	4.5 Assemble the Coupling

	5. Technical Drawing
	6. Export and Save
	Figures and Diagrams


